<!DOCTYPE html>
<html lang="en" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">

<head>
  <meta charset="UTF-8" />
  <meta name="viewport" content="width=device-width,initial-scale=1">
  <meta http-equiv="X-UA-Compatible" content="chrome=1">
  <title>Instagram Search millions of profiles with contact details</title>

  <!-- Basic -->
  <link rel=profile href="https://gmpg.org/xfn/11">
  <meta name="description" content="Instagram Search millions of profiles with contact details" />
  <meta name="msvalidate.01" content="E516B1FAF189E91C5FD54F14F8B74314">
  <meta name="p:domain_verify" content="455272b0fd7b4ecf9264f4a131ce236b">
  <meta name="yandex-verification" content="5aab3976844e145a">

  <!-- Preconnect Font -->
  <link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin>
  <link rel=alternate type=application/rss+xml title="NinjaOutreach &raquo; Feed" href="ninjaoutreach.com/feed/">
  
  <link rel="canonical" href="https://ninjaoutreach.cominstagram/search">
  

  <!-- Application/LD+JSON -->
  <script type=application/ld+json>
    {
      "@context":"http:\/\/schema.org",
      "@type":"WebSite",
      "@id":"#website",
      "url":"https:\/\/ninjaoutreach.com\/",
      "name":"NinjaOutreach"
    }
  </script>
  <script type=application/ld+json>
    {
      "@context":"http:\/\/schema.org",
      "@type":"Organization",
      "url":"https:\/\/ninjaoutreach.com\/",
      "sameAs":["https:\/\/www.facebook.com\/ninjaoutreach","https:\/\/www.instagram.com\/ninjaoutreach\/","https:\/\/www.linkedin.com\/company\/ninjaoutreach\/","https:\/\/www.youtube.com\/c\/ninjaoutreach","https:\/\/twitter.com\/ninjaoutreach"],
      "@id":"#organization",
      "name":"Ninja Outreach",
      "logo":"https:\/\/ninjaoutreach.com\/img\/JustLogo.png"
    }
  </script>

  <!-- Font weights -->
  <link href="https://fonts.googleapis.com/css?family=Open+Sans:400,700&display=swap" rel="stylesheet">

  <!-- DNS CACHE -->
  
  <link rel="dns-prefetch" href="https://stackpath.bootstrapcdn.com" />
  
  <link rel="dns-prefetch" href="https://code.jquery.com" />
  
  <link rel=stylesheet id=bootstrap4-css href=https://stackpath.bootstrapcdn.com/bootstrap/4.3.1/css/bootstrap.min.css type=text/css media=all>

  <!-- NinjaOutreach -->
  <meta name="author" content="NinjaOutreach" />
  <meta name="author-mail" content="support@ninjaoutreach.com" />
  <meta name="revisit-after" content="6 hours" />
  <meta name="rating" content="general" />
  <meta name="language" content="en" />
  <meta name="hostname" content="ninjaoutreach.com" />
  <meta name="viewport" content="width=device-width, initial-scale=1" />
  <meta name=verifyownership content=e5d15b1e4717f74b3bab7c5cb19465d3>

  <!-- Translations -->
  
  <link rel="alternate" hreflang="en" href="ninjaoutreach.cominstagram/search" />
  
  <link rel="alternate" hreflang="it" href="it.ninjaoutreach.cominstagram/search" />
  

  <!-- PWA -->
  

  <!-- Google Webmaster -->
  <meta name="google-site-verification" content="GTM-MMZDRST" />
  <meta name="google-analytics" content="UA-52626549-1">

  <!-- Android -->
  <meta name="theme-color" content="#ffffff">

  <!-- Twitter -->
  <meta name=twitter:card content=summary_large_image>
  <meta name=twitter:description content="Instagram Search millions of profiles with contact details">
  <meta name=twitter:title content="Instagram Search millions of profiles with contact details">
  <meta name=twitter:site content="@ninjaoutreach">
  <meta name=twitter:image content="/img/screenshot/OG_image.png">
  <meta name=twitter:creator content="@ninjaoutreach">

  <!-- Favicon -->
  <link rel="apple-touch-icon" sizes="180x180" href="/icons/apple-touch-icon.png">
  <link rel=apple-touch-icon-precomposed href=/icons/apple-touch-icon.png>
  <link rel="icon" type="image/png" sizes="32x32" href="/icons/favicon-32x32.png">
  <link rel="icon" type="image/png" sizes="16x16" href="/icons/favicon-16x16.png">
  <link rel="icon" type="image/png" sizes="192x192" href="/icons/favicon-192x192.png">
  <link rel="manifest" href="/icons/site.webmanifest">
  <link rel="mask-icon" href="/icons/safari-pinned-tab.svg" color="#5bbad5">
  <link rel="shortcut icon" href="/icons/favicon.ico">
  <meta name="msapplication-TileColor" content="#2b5797">
  <meta name="msapplication-TileImage" content="/icons/favicon.png">
  <meta name="msapplication-config" content="/icons/browserconfig.xml">

  <!-- Page -->
  <link rel=stylesheet id=pages-header-css href="/css/main-e9e92ef76a.min.css" type=text/css media=all>

  
    
    <link rel=stylesheet id=pages-css href="https://cdnjs.cloudflare.com/ajax/libs/select2/4.0.10/css/select2.min.css" type=text/css media=all>
    
    <link rel=stylesheet id=pages-css href="/css/search-page-4f36aadf31.min.css" type=text/css media=all>
    
    
      <script src="https://code.jquery.com/jquery-3.1.1.min.js"
        
      ></script>
    
      <script src="https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.12.2/umd/popper.min.js"
        
      ></script>
    
      <script src="https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0/js/bootstrap.min.js"
        
      ></script>
    
      <script src="https://cdnjs.cloudflare.com/ajax/libs/select2/4.0.10/js/select2.min.js"
        
      ></script>
    
      <script src="https://cdn.jsdelivr.net/npm/vue/dist/vue.min.js"
        
      ></script>
    
  
  <script src="/js/full-094ec34de5.min.js" defer></script>

  <!-- Google Analytics -->
  <script>
    (function (i, s, o, g, r, a, m) {
      i['GoogleAnalyticsObject'] = r;
      i[r] = i[r] || function () {
        (i[r].q = i[r].q || []).push(arguments)
      }, i[r].l = 1 * new Date();
      a = s.createElement(o),
        m = s.getElementsByTagName(o)[0];
      a.async = 1;
      a.src = g;
      m.parentNode.insertBefore(a, m)
    })(window, document, 'script', 'https://www.google-analytics.com/analytics.js', 'ga');
    ga('create', 'UA-52626549-1', 'auto');
    ga('require', 'GTM-MMZDRST');
    ga('set', 'dimension1', '');
    ga('send', 'pageview');
    ga('require', 'ec');
  </script>

  <!-- Hotjar Tracking Code for www.ninjaoutreach.com -->
  <script>
    // only enabled on Monday
    if ((new Date()).getDay() === 1) {
      (function(h,o,t,j,a,r){
          h.hj=h.hj||function(){(h.hj.q=h.hj.q||[]).push(arguments)};
          h._hjSettings={hjid:1116234,hjsv:6};
          a=o.getElementsByTagName('head')[0];
          r=o.createElement('script');r.async=1;
          r.src=t+h._hjSettings.hjid+j+h._hjSettings.hjsv;
          a.appendChild(r);
      })(window,document,'https://static.hotjar.com/c/hotjar-','.js?sv=');
    }
  </script>
</head>


  <body id="ninjaoutreach"
    class="page-template-default page page-id-1525515 oceanwp-theme sidebar-mobile no-header-border default-breakpoint content-full-width content-max-width page-header-disabled has-blog-grid no-margins elementor-default elementor-page elementor-page-1525515">
    <nav class="primary_manu_influencers" id="primary_manu_influencers">
  <div class="container">
    <div class="row">
      <div class="logo col-md-2 col-sm-12 d-flex align-items-center my-auto col">
        <div class="menu-button-wrapper">
          <button class="menu-button" id="btn_main_menu" alt="Menu">
            <span class="icon0-menu icons"></span>
          </button>
        </div>
        <a href="/" data-elementor-open-lightbox="" class="no-lightbox">
          <img width="163" height="30" src="/img/NinjaOutreach.png" class="attachment-full size-full initial loading"
            alt="NinjaOutreach Logo" title="NinjaOutreach Logo" data-was-processed="true" />
        </a>
      </div>
      <div class="col-xl-5 col ninja-primary-menu my-auto ">
        <div class="navbar navbar-expand-md navbar-light ">
          <div class="collapse navbar-collapse">
            <ul id="menu-primary-menu" class="navbar-nav ml-auto">
              <li id="menu-item-1519356" class="menu-item menu-item-type-custom menu-item-object-custom current-menu-item current_page_item menu-item-home menu-item-1519356 nav-item
                  
                ">
                <a title="Home" href="/" class="nav-link">Home</a>
              </li>
              <li id="menu-item-1526926" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1526926 nav-item
                
                ">
                <a title="Search" href="/search/" class="nav-link">Search</a>
              </li>
              <li id="menu-item-1527195" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1527195 nav-item
                
                ">
                <a title="Case Studies" href="/case-studies/" class="nav-link">Case Studies</a>
              </li>
              <li id="menu-item-1522982"
                class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-1522982 nav-item">
                <a title="Features" href="#" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false"
                  class="dropdown-toggle nav-link" id="menu-item-dropdown-1522982">Features</a>
                <div class="features-overlay" id="features-overlay"></div>
                <ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-1522982" role="menu">
                  <li id="menu-item-1524771"
                    class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1524771 nav-item">
                    <a title="Business Lead Generation : Get Leads with a Simple Search"
                      href="/business-leads-generation/" class="dropdown-item">Business Lead Generation : Get Leads with
                      a Simple
                      Search</a>
                  </li>
                  <li id="menu-item-517090"
                    class="menu-item menu-item-type-custom menu-item-object-custom menu-item-517090 nav-item">
                    <a title="Find Instagram Influencers" href="/find-instagram-influencers/" class="dropdown-item">Find
                      Instagram Influencers</a>
                  </li>
                  <li id="menu-item-1522981"
                    class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1522981 nav-item">
                    <a title="Find Top Twitter Influencers" href="/find-top-twitter-influencers/"
                      class="dropdown-item">Find Top Twitter Influencers</a>
                  </li>
                  <li id="menu-item-1523527"
                    class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1523527 nav-item">
                    <a title="Influencer Marketing Agency Software" href="/influencer-marketing-agency-platform/"
                      class="dropdown-item">Influencer Marketing Agency Software</a>
                  </li>
                  <li id="menu-item-1523523"
                    class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1523523 nav-item">
                    <a title="Link Building Software" href="/link-building-software/" class="dropdown-item">Link
                      Building Software</a>
                  </li>
                  <li id="menu-item-1524774"
                    class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1524774 nav-item">
                    <a title="Contact Relationship Management" href="/contact-relationship-management/"
                      class="dropdown-item">Contact Relationship Management</a>
                  </li>
                  <li id="menu-item-4565"
                    class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4565 nav-item">
                    <a title="Scalable and Effective Influencer Outreach Tool" href="/influencer-outreach-tool/"
                      class="dropdown-item">Scalable and Effective Influencer Outreach Tool</a>
                  </li>
                </ul>
              </li>
            </ul>
          </div>
        </div>
      </div>
      <div class="col-xl-5 col text-sm-right my-auto ninja-primary-buttons  p-sm-0">
        <a href="/social-api/" class="instagram_api_btn" title="Instagram API">
          Instagram API
        </a>
        
        <a href="https://app.ninjaoutreach.com/Account/Login?ReturnUrl=%2F" class="menu_light_btn" title="Sign In">Sign In</a>
        <a href="/pricing" class="green_btn mr-3" id="start_free_trail_btn"
          data-ga-event-cat="Header CTA click > Start Free Trial" title="Start Free Trial">Start Free Trial</a>
        
      </div>
    </div>
  </div>
</nav>
<div id="main_menu" class="main-menu">
  <div id="backgound_overlay" class="backgound-overlay">
  </div>
  <div class="menu-title container">
    <div class="row">
      <div class="logo d-flex align-items-center my-auto col">
        <a href="/" data-elementor-open-lightbox="" class="no-lightbox">
          <img width="163" height="30" src="/img/NinjaOutreach.png" class="attachment-full size-full initial loading"
            alt="NinjaOutreach Logo" title="NinjaOutreach Logo" data-was-processed="true" />
        </a>
        <div class="close-menu-button-wrapper">
          <button class="close-menu-button" id="btn_close_main_menu">
            <span>&times;</span>
          </button>
        </div>
      </div>
    </div>
  </div>
  <div class="menu-content pt-4">
    <ul class="menu-items">
      <li class="menu-item--mobile
        
      ">
        <a href="/" class="menu-item-link no-line">
          Home
        </a>
      </li>
      <li class="menu-item--mobile
        
      ">
        <a href="/search" class="menu-item-link">
          Search
        </a>
      </li>
      <li class="menu-item--mobile
        
      ">
        <a href="/case-studies" class="menu-item-link">
          Case Studies
        </a>
      </li>
      <li class="menu-item--mobile">
        <a id="collapseFeatures" class="menu-item-link menu-item-link--more collapsed">
          Features
        </a>
        <div class="sub-menu mb-2 collapse" id="collapseFeaturesMenu" style="display: none;">
          <ul class="sub-menu-items">
            <li class="sub-menu-item
              
            ">
              <a href="/business-leads-generation/" class="sub-menu-item-link">
                Business Lead Generation : Get Leads with a Simple Search
              </a>
            </li>
            <li class="sub-menu-item
              
            ">
              <a href="/find-instagram-influencers/" class="sub-menu-item-link">
                Find Instagram Influencers
              </a>
            </li>
            <li class="sub-menu-item
              
            ">
              <a href="/find-top-twitter-influencers/" class="sub-menu-item-link">
                Find Top Twitter Influencers
              </a>
            </li>

            <li class="sub-menu-item
              
            ">
              <a href="/influencer-marketing-agency-platform/" class="sub-menu-item-link">
                Influencer Marketing Agency Software
              </a>
            </li>
            <li class="sub-menu-item
              
            ">
              <a href="/link-building-software/" class="sub-menu-item-link">
                Link Building Software
              </a>
            </li>

            <li class="sub-menu-item
              
            ">
              <a href="/contact-relationship-management/" class="sub-menu-item-link">
                Contact Relationship Management
              </a>
            </li>
            <li class="sub-menu-item
              
            ">
              <a href="/influencer-outreach-tool/" class="sub-menu-item-link">
                Scalable and Effective Influencer Outreach Tool
              </a>
            </li>
          </ul>
          <div>
      </li>

      <li class="menu-item--mobile
        
      ">
        <a href="/social-api/" class="menu-item-link">
          Instagram API
        </a>
      </li>
      
      <li class="menu-item--mobile mt-5">
        <a href="https://app.ninjaoutreach.com/Account/Login?ReturnUrl=%2F" class="menu_light_btn" title="Sign In">Sign In</a>
      </li>
      <li class="menu-item--mobile mt-3 mb-5">
        <a href="/pricing" class="green_btn" data-ga-event-cat="Header CTA click > Start Free Trial"
          title="Start Free Trial">Start Free Trial</a>
      </li>
      
    </ul>
  </div>
</div>
 
    <div id="vapp" class="page-content">
      
<div class="topbars-group" id="search_topbar">
<div class="search-bar">
  <div class="container d-flex justify-content-between">
    <div class="d-flex w-xs-100">
      <div class="search-input-wrapper mr-3">
        <input
          :class="`search-input ${searchInput ? '' : 'blank'}`"
          type="text"
          placeholder="Search Instagram"
          v-model="searchInput"
          v-on:keyup="searchInputChanged($event)"
        >
        <button class="search-button" @click="search(true)"><span class="icon3-search_light_icon"></button>
      </div>

      <div class="location-selector-wrapper mr-3" :class="resolvedCountry ? '' : 'blank'">
        <select style="width: 100%" id="location_autocomplete" class="location-autocomplete blank"></select>
        <button v-if="resolvedCountry" @click="clearResolvedLocation" class="location-autocomplate-clear"><span>&times;</span></button>
      </div>
      <div class="search-result">
        
      </div>
      <div class="location-button-wrapper">
        <button class="location-button" id="show_location_button" @click="showLocationSidebar">
          <span class="icon3-location_normal_icon">
        </button>
      </div>
    </div>

    <div class="d-flex">
      <div class="search-filter">
        <button class="search-filter-button" id="show_filter_button" @click="showFilterSidebar">
          <span class="icon3-filter_normal_icon">
        </button>
      </div>
    </div>

  </div>
</div>

<div class="categories-bar">
  <div class="container">
    <div class="category-tags-wrapper ml-3">
      
      <a 
        class="category-tag" 
        :class="resolvedCategories.indexOf('Beauty and Cosmetics') > -1 ? 'active' : ''"
        @click="selectTopCategory('Beauty and Cosmetics')"
      >
        <div class="category-tag-icon"><span class="icon1-beauty_icon"></span></div>
        <div class="category-tag-label">Beauty</div>
      </a>
      
      <a 
        class="category-tag" 
        :class="resolvedCategories.indexOf('Fashion') > -1 ? 'active' : ''"
        @click="selectTopCategory('Fashion')"
      >
        <div class="category-tag-icon"><span class="icon1-fashion_icon2x"></span></div>
        <div class="category-tag-label">Fashion</div>
      </a>
      
      <a 
        class="category-tag" 
        :class="resolvedCategories.indexOf('Fitness') > -1 ? 'active' : ''"
        @click="selectTopCategory('Fitness')"
      >
        <div class="category-tag-icon"><span class="icon1-fitness_icon2x"></span></div>
        <div class="category-tag-label">Fitness</div>
      </a>
      
      <a 
        class="category-tag" 
        :class="resolvedCategories.indexOf('Clothes and Accessories') > -1 ? 'active' : ''"
        @click="selectTopCategory('Clothes and Accessories')"
      >
        <div class="category-tag-icon"><span class="icon1-clothes_accessories_icon2x"></span></div>
        <div class="category-tag-label">Clothes &amp; Accessories</div>
      </a>
      
      <a 
        class="category-tag" 
        :class="resolvedCategories.indexOf('Lifestyle') > -1 ? 'active' : ''"
        @click="selectTopCategory('Lifestyle')"
      >
        <div class="category-tag-icon"><span class="icon1-lifestyle_icon2x"></span></div>
        <div class="category-tag-label">Lifestyle</div>
      </a>
      
      <a 
        class="category-tag" 
        :class="resolvedCategories.indexOf('Food') > -1 ? 'active' : ''"
        @click="selectTopCategory('Food')"
      >
        <div class="category-tag-icon"><span class="icon1-food_icon2x"></span></div>
        <div class="category-tag-label">Food</div>
      </a>
      
      <a 
        class="category-tag" 
        :class="resolvedCategories.indexOf('Health') > -1 ? 'active' : ''"
        @click="selectTopCategory('Health')"
      >
        <div class="category-tag-icon"><span class="icon1-health_icon2x"></span></div>
        <div class="category-tag-label">Health</div>
      </a>
      
      <a 
        class="category-tag" 
        :class="resolvedCategories.indexOf('Travel') > -1 ? 'active' : ''"
        @click="selectTopCategory('Travel')"
      >
        <div class="category-tag-icon"><span class="icon1-travel_icon2x"></span></div>
        <div class="category-tag-label">Travel</div>
      </a>
      
    </div>
    <div class="category-expand-button-wrapper">
      <button class="category-expand-button" id="expand_categories_button" @click="showCategoriesSidbar">
        <div class="button-icon mr-2">
          <span class="icon3-expand_arrow_normal_icon"></span>
        </div>
        <div class="button-label">Expand</div>
      </button>
    </div>
  </div>
</div>
</div>



<div class="container d-flex justify-content-center align-items-center flex-column mt-5">
  <h3 class="mt-5">Wow, you've got something really specific in mind.</h3>
  <p>Try changing the search criteria to see better results.</p>
</div>

<nav id="categories_panel" class="sidebar">
  <div id="dismiss" @click="hideSidebars">
    <span>&times;</span>
  </div>
  <div class="sidebar-arrow_open_icon-wrapper" @click="hideSidebars">
    <span class="icon3-arrow_open_icon"></span>
  </div>
  <div class="sidebar-header">
    <span class="icon3-categories_icon mr-2"></span><h3>Categories</h3>
  </div>

  <div class="search-input-wrapper">
    <input 
      class="search-input search-input-category" 
      type="text" 
      placeholder="Search Category"
      v-model="searchCategoryInput"
      :class="searchCategoryInput ? '' : 'blank'"
    >
    <span class="icon3-search_light_icon"></span>
  </div>

  <div class="profile-tags-wrapper--sidebar" v-if="categoriesList">
    <div class="profile-tags--sidebar">
      <a 
        v-for="category in categoriesList"
        class="profile-tag" 
        :class="isActiveCategory(category.category)?'active':''"
        v-show="!searchCategoryInput || category.category.toLowerCase().includes(searchCategoryInput.toLowerCase())"
        @click="selectSidebarCategory(category.category)"
      >
        [[category.category]]
      </a>
    </div>
  </div>

  <div class="sidebar-bottons">
    <button class="button-cancel" @click="hideSidebars">Cancel</button>
    <button class="button-apply" @click="applyCategories">Apply</button>
  </div>

</nav>
<nav id="filter_panel" class="sidebar">
  <div class="sidebar-arrow_open_icon-wrapper" @click="hideSidebars">
    <span class="icon3-arrow_open_icon"></span>
  </div>
  <div class="sidebar-header filter-sidebar-header">
    <h3>Filter</h3>
    <button class="filter-reset-button" @click="resetFilter">
      <img src="/img/reset_icon.svg">Reset
    </button>
  </div>
  <div class="filter-blocks-wrapper">
    <div class="filter-block filter-block--percent filter-block-bottomline">
      <h4 class="filter-block-label">Engagement Rate</h4>
      <div class="btn-group-toggle" data-toggle="buttons">
        <div class="d-flex align-items-center flex-wrap">
          
          <label 
            class="btn btn-option btn-option--engagement-rate ml-0" 
            @click="setSelectedEngagementRates(0, 1)"
            :class="0==selectedEngagementRateGte && 1==selectedEngagementRateLte  ? 'active' : ''"
          >
            <input 
              type="radio" 
              name="options" 
              autocomplete="off"
              
            > 
            
            < 1%
            
          </label>
          
          <label 
            class="btn btn-option btn-option--engagement-rate ml-0" 
            @click="setSelectedEngagementRates(1, 2)"
            :class="1==selectedEngagementRateGte && 2==selectedEngagementRateLte  ? 'active' : ''"
          >
            <input 
              type="radio" 
              name="options" 
              autocomplete="off"
              
            > 
            
            1% - 2% 
            
          </label>
          
          <label 
            class="btn btn-option btn-option--engagement-rate ml-0" 
            @click="setSelectedEngagementRates(2, 5)"
            :class="2==selectedEngagementRateGte && 5==selectedEngagementRateLte  ? 'active' : ''"
          >
            <input 
              type="radio" 
              name="options" 
              autocomplete="off"
              
            > 
            
            2% - 5% 
            
          </label>
          
          <label 
            class="btn btn-option btn-option--engagement-rate ml-0" 
            @click="setSelectedEngagementRates(5, 10)"
            :class="5==selectedEngagementRateGte && 10==selectedEngagementRateLte  ? 'active' : ''"
          >
            <input 
              type="radio" 
              name="options" 
              autocomplete="off"
              
            > 
            
            5% - 10% 
            
          </label>
          
          <button class="filter-collapse-button collapsed" type="button" data-toggle="collapse" data-target="#collapseCustomEngagementRate" aria-expanded="false" aria-controls="collapseCustomEngagementRate">
            <div class="button-icon mr-2">
              <span class="icon3-expand_arrow_normal_icon"></span>
            </div>
          </button>           
        </div>
         

        <div class="collapse" id="collapseCustomEngagementRate">
          <div class="d-flex align-items-center my-3" >
            <p class="mr-2">More than</p>
            <input 
              type="number" 
              :step="constants.ENGAGEMENT_RATE_STEP"
              :min="constants.ENGAGEMENT_RATE_MIN" 
              :max="Math.min(constants.ENGAGEMENT_RATE_MAX, selectedEngagementRateLte)" 
              v-model="selectedEngagementRateGte" 
              v-on:blur="validateEngagementRateGte"
              v-on:keyup.enter="validateEngagementRateGte"
              class="filter-block--input"
            >
            <p>%</p>
            <p class="mr-2 ml-3">Less than</p>
            <input 
              type="number" 
              :step="constants.ENGAGEMENT_RATE_STEP"
              :min="Math.max(constants.ENGAGEMENT_RATE_MIN, selectedEngagementRateGte)" 
              :max="constants.ENGAGEMENT_RATE_MAX" 
              v-model="selectedEngagementRateLte" 
              v-on:blur="validateEngagementRateLte"
              v-on:keyup.enter="validateEngagementRateLte"
              class="filter-block--input"
            >
            <p>%</p>
          </div>
        </div>
      </div>
    </div>

    <div class="filter-block filter-block--bitnumber filter-block-bottomline mt-3">
      <h4 class="filter-block-label">Followers</h4>
      <div class="btn-group-toggle" data-toggle="buttons">
        <div class="d-flex align-items-center flex-wrap">
          
          <label 
            class="btn btn-option btn-option--followers ml-0" 
            @click="setSelectedFollowers(10000, 20000)"
            :class="10000==selectedFollowersGte && 20000==selectedFollowersLte  ? 'active' : ''"
          >
            <input 
              type="radio" 
              name="options" 
              autocomplete="off"
            > 10,000 - 20,000
          </label>
          
          <label 
            class="btn btn-option btn-option--followers ml-0" 
            @click="setSelectedFollowers(20000, 50000)"
            :class="20000==selectedFollowersGte && 50000==selectedFollowersLte  ? 'active' : ''"
          >
            <input 
              type="radio" 
              name="options" 
              autocomplete="off"
            > 20,000 - 50,000
          </label>
          
          <label 
            class="btn btn-option btn-option--followers ml-0" 
            @click="setSelectedFollowers(50000, 100000)"
            :class="50000==selectedFollowersGte && 100000==selectedFollowersLte  ? 'active' : ''"
          >
            <input 
              type="radio" 
              name="options" 
              autocomplete="off"
            > 50,000 - 100,000
          </label>
          
          <button class="filter-collapse-button collapsed" type="button" data-toggle="collapse" data-target="#collapseCustomFollowers" aria-expanded="false" aria-controls="collapseCustomFollowers">
            <div class="button-icon mr-2">
              <span class="icon3-expand_arrow_normal_icon"></span>
            </div>
          </button>   
        </div>
        <div class="collapse" id="collapseCustomFollowers">
          <div class="d-flex align-items-center my-3">
            <p class="mr-2">Under</p>
            <input 
              type="number" 
              :step="constants.FOLLOWERS_STEP"
              :min="constants.FOLLOWERS_MIN" 
              :max="Math.min(constants.FOLLOWERS_MAX, selectedFollowersLte)" 
              v-model="selectedFollowersGte"
              v-on:blur="validateFollowersGte"
              v-on:keyup.enter="validateFollowersGte"
              class="filter-block--input"
            >
            <p class="mr-2 ml-3">Over</p>  
            <input 
              type="number" 
              :step="constants.FOLLOWERS_STEP"
              :min="Math.max(constants.FOLLOWERS_MIN, selectedFollowersGte)" 
              :max="constants.FOLLOWERS_MAX" 
              v-model="selectedFollowersLte"
              v-on:blur="validateFollowersLte"
              v-on:keyup.enter="validateFollowersLte"
              class="filter-block--input"
            >
          </div>
        </div>
      </div>
    </div>

    <div class="filter-block filter-block-bottomline mt-3">
      <div class="d-flex justify-content-between align-items-center">
        <h4 class="filter-block-label">Categories</h4>
        <div class="btn-group-toggle round-switch" data-toggle="buttons">
          <div class="d-flex align-items-center">
            <label class="btn btn-option ml-0" @click="setSelectedCategoryAnd(true)" :class="selectedCategoryAnd ? 'active' : ''">
              <input type="radio" name="options" autocomplete="off"> and
            </label>
            <label class="btn btn-option"  @click="setSelectedCategoryAnd(false)" :class="selectedCategoryAnd ? '' : 'active'">
              <input type="radio" name="options" autocomplete="off"> or
            </label>
          </div>
        </div>
      </div>
      <div class="w-100 mt-3 mb-1">
        <select id="category_selector" multiple="multiple" style="width: 100%">
          <option
            v-for="category in categoriesList"
          >
            [[ category.category ]]
          </option>
        </select>         
      </div> 
    </div>

    <div class="filter-block my-3">
      <div class="d-flex mb-1">
        <h4 class="filter-block-label">Location</h4>
      </div>
      <div class="location-selector-wrapper">
        <select style="width: 100%" id="location_autocomplete_filter" class="location-autocomplete"></select>
        <button v-if="selectedCountry" @click="clearSelectedLocation" class="location-autocomplate-clear"><span>&times;</span></button>
      </div>
    </div>
  </div>

  <div class="sidebar-bottons">
    <button class="button-cancel" @click="hideSidebars">Cancel</button>
    <button class="button-apply" @click="applyFilter">Apply</button>
  </div>

</nav>
<nav id="location_panel" class="sidebar">
  <div id="dismiss" @click="hideSidebars">
    <span>&times;</span>
  </div>
  <div class="sidebar-arrow_open_icon-wrapper" @click="hideSidebars">
    <span class="icon3-arrow_open_icon"></span>
  </div>

  <div class="sidebar-header">
    <span class="icon3-location_normal_icon mr-2"></span><h3>Location</h3>
  </div>
  
  <div class="location-input-wrapper">
    <div class="location-selector-wrapper mx-4">
      <select style="width: 100%" id="location_autocomplete_extend" class="location-autocomplete blank"></select>
      <button v-if="selectedCountry" @click="clearSelectedLocation" class="location-autocomplate-clear"><span>&times;</span></button>
    </div>    
  </div>

  <div class="sidebar-bottons">
    <button class="button-cancel" @click="hideSidebars">Cancel</button>
    <button class="button-apply" @click="applyLocation">Apply</button>
  </div>

</nav>
<div class="overlay" @click="hideSidebars"></div>

    </div>
  </body>
  <script>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</script>
  

</html>